Using Oracle Java SE Embedded Support in NetBeans IDE

This tutorial needs a review. You can open a JIRA issue, or edit it in GitHub following these contribution guidelines.

Oracle Java Standard Edition Embedded (Oracle Java SE Embedded) enables users to develop highly functional, reliable and portable applications for powerful embedded systems. NetBeans IDE supports Java SE Embedded features, such as footprint, memory, power, platform support, etc.

In this tutorial, you will learn how to get started with Java SE Embedded in NetBeans IDE and how to use the IDE support for Java SE Embedded.

Setting Up a Remote Platform in NetBeans IDE

Once Oracle Java SE Embedded runtime is downloaded and installed on your remote machine (Raspberry Pi is used for demonstration purposes in this tutorial), you need to set up NetBeans IDE with the remote platform as follows:

  • activate the Java SE feature in NetBeans IDE

  • install a remote Java SE platform in NetBeans IDE

The remote operating system must be UNIX. Windows is not supported.

To activate the Java SE feature in the IDE:

  1. Choose Tools > Plugins from the main IDE’s toolbar.

  2. In the Plugins dialog box, click the Installed tab and select Java SE in the list of available features.

plugins small
  1. Click Activate.

  2. At the Welcome panel of the Installer dialog box, click Activate.

  3. When the activation is successfully completed, click Finish.

  4. Click Close to close the Plugins dialog box.

To install a remote Java SE platform in NetBeans IDE:

  1. Choose Tools > Java Platforms. The Java Platform Manager dialog box displays.

jpmanager small
  1. Click Add Platform.

  2. In the Select Platform Type of the Add Java Platform wizard, select Remote Java Standard Edition and click Next. The IDE displays the Add Java Platform dialog box.

addjp small
  1. Specify the remote platform details such as the name, the IP address or DNS name of the device, login, password, and the path to the JRE on the remote device.

The target operating system must be UNIX (Windows is not supported).
  1. Click Finish. The IDE validates the remote JRE by executing a probe and downloads the remote JRE system properties. A new remote Java SE platform displays in the Java Platform Manager dialog box.

jpremote small

Now your NetBeans IDE is set up for remote Java SE development.

Creating and Running a Project in the IDE

Now let us create a project that is going to be first run in the IDE and then on the remote platform.

To create a project:

  1. In the IDE, choose File > New Project.

  2. In the New Project wizard, choose the Java category and select Java Application in the Projects list. Click Next.

  3. In the Name and Location page of the wizard, do the following:

    • In the Project Name field, type EmbeddedCalculator.

    • Leave the Use Dedicated Folder for Storing Libraries checkbox unselected.

    • In the Create Main Class field, type embeddedcalculator.EmbeddedCalculator.

wizard small
  1. Click Finish. The IDE creates and opens the Java SE project in the Projects window.

  2. Replace the // TODO code application logic here line with the following code:

    int a = 1;
    int b = 2;
    int c = a + b;
    System.out.println (c);
  1. Save your changes by choosing File > Save.

To test your application, right-click the project name and choose Run from the context menu. The calculated output can be viewed in the Output window (Window > Output).

run ide

Configuring a Project to Use a Remote Platform

To develop a Java SE embedded application on a remote platform using compact1, compact2, or compact3 runtime platforms, JDK 8 needs to be registered in the IDE.

To enable JDK 8 support in NetBeans IDE:

  1. In the IDE, choose Tools > Java Platforms from the main menu.

  2. Click Add Platform in the Java Platform Manager dialog.

  3. In the Add Java Platform dialog, select Java Standard Edition and click Next.

  4. Specify the directory that contains the JDK and click Next.

jdk8 small
  1. Verify that the default locations of the platform sources zip file and API documentation are valid. Click Finish to close the Add Java Platform dialog box. JDK 8 is registered as a platform in the IDE.

jdk8registered small
  1. Click Close.

To configure your project to use JDK 8:

  1. Right-click the EmbeddedCalculator project in the Projects window and select Properties from the context menu.

  2. In the Project Properties dialog box, choose the Libraries category and set JDK 1.8 as the Java Platform.

prj jdk8 small
  1. Select the Sources category and set Source/Binary Format to JDK 8.

prj source jdk8 small
  1. Specify the profile that is used as runtime on a remote platform (for example, Compact 2).

prj jdk8 profile small
  1. Click OK to save the changes. Your project is set to recognize a particular runtime on a remote platform.

Running a Project on a Remote Platfrom

You can run and debug the application on a remote device after setting the project configuration to a configuration different from the default one.

To create a new configuration:

  1. Right-click the project name in the Projects window and select Properties from the context menu.

  2. Choose the Run category.

  3. Click New to the right of the Configuration drop-down list.

  4. In the Create New Configuration dalog box, specify the name of a new configuration and click OK.

  5. Select the runtime platform name in the Runtime Platform drop-down list.

config runtime small
  1. Click OK to save your edits.

If you run the project on a remote platform (Run > Run Project (project name)), the output will look similar to what is shown in the figure below.

run remote small

To switch between project configurations:

  • Choose Run > Set Project Configuration > configuration name or right-click the project name and choose Set Configuration > configuration name from the context menu.

switch config small