Debugging C/C++ Projects Tutorial

This tutorial needs a review. You can open a JIRA issue, or edit it in GitHub following these contribution guidelines.

March 2013 [Revision number: V8.0-1]

The following short tutorial takes you through some of the features for debugging a C or C++ project in NetBeans IDE.

Requirements

To follow this tutorial, you need the following software and resources.

Software or Resource Version Required

NetBeans IDE

version 7.4 or 8.0 with NetBeans C/C+ plugin module+

Java Developer Kit (JDK)

version 7 or 8

See the NetBeans IDE Installation Instructions and + Configuring the NetBeans IDE for C/C+/Fortran for information on downloading and installing the required software.

Creating the Sample Project

The NetBeans IDE with C/C++ uses the gdb debugger and provides numerous features for debugging your projects. To explore these features, you will use the Quote project. If you have not already created this project, do the following:

  1. Choose File > New Project.

  2. In the project wizard, expand the Samples category and the C/C++ subcategory.

  3. Select the Applications subcategory, then select the Quote project. Click Next, then click Finish.

Creating Breakpoints

You can create and manipulate breakpoints in your code at any time without starting a debugging session.

Creating and Removing a Line Breakpoint

  1. In the Quote_1 project, open the quote.cc file.

  2. Set a line breakpoint by clicking in the left margin of the Source Editor window next to line 171 ( response = readChar("Enter disk module type: (S for single disks, R for RAID; Q - exit)", 'S'); ). The line is highlighted in red to indicate that the breakpoint is set.

line breakpoint1
  1. You could remove the breakpoint by clicking on the icon in the left margin.

  1. Choose Window > Debugging > Breakpoints to open the Breakpoints window. Your line breakpoint is listed under the C/C++ node.

line breakpoint2
  1. Expand the C/C++ node to see your breakpoint.

line breakpoint2 expand

Creating a Function Breakpoint

  1. Click the Create New Breakpoint button in the left margin of the Breakpoints window or choose Debug > New Breakpoint (Ctrl+Shift+F8) to open the New Breakpoint dialog box.

  2. In the Debugger Type list, select Native.

  3. In the Breakpoint Type list, select Function.

  4. Type the function name Customer::GetDiscount in the Function Name text field. Click OK.

function breakpoint1
  1. Your function breakpoint is set and is added to the list in the Breakpoints window.

function breakpoint2
  1. Click the Select Breakpoint Groups button in the left margin to organize the breakpoints into different groups and select Type.

group breakpoint type
  1. Expand the File:Line and Function groups to display your breakpoints.

breakpoint types

Starting a Debugging Session

When you start a debugging session, the IDE starts the gdb debugger, then runs the application inside the debugger. The IDE automatically opens the debugger windows and debugger toolbar and prints debugger output to the Output window.

  1. Start a debugging session for the Quote_1 project by clicking the Debug Project button debugbutton or by choosing Debug > Debug Project. The debugger starts and the application runs. The debug toolbar is displayed.

debugger toolbar
  1. Open the Sessions window by choosing Window > Debugging > Sessions. The debugging session is shown in this window.

Inspecting the State of the Application

  1. The Quote_1 application prompts you for input in the Output (Debug) window.

  2. Enter a customer name after the "Enter customer name:" prompt.

The application stops at the Customer::GetDiscount function breakpoint you set earlier and the customer.cc file opens in the editor at the line where the funtion is called. The Breakpoints window lists the two breakpoints you set earlier. The green program counter arrow appears on top of the breakpoint icon of the function breakpoint.

function breakpoint3
  1. Click the tab for the Call Stack window or choose Window > Debugging > Call Stack. The call stack shows three frames.

call stack
  1. Open the Variables window and note that one variable is displayed.

  1. Click the expand icons to expand the structure.

local variables1
  1. Click the Continue button in the toolbar. The GetDiscount function is executed, printing the customer discount to the Output (Debug) window. Then you are prompted for input.

  1. Enter the input in response to the prompts.

The program stops at the next breakpoint, the line breakpoint you set earlier. In the quote.cc file, the green program counter arrow appears on top of the breakpoint icon indicating the line on which the program is stopped.

line breakpoint3
  1. Click the Variables tab and note the long list of variables.

local variables2
  1. Click the Call Stack tab and note that there is now one frame in the stack.

  1. Choose Window > Debugging > Registers. The Registers window opens, displaying the current contents of the registers.

registers
  1. Choose Window > Debugging > Disassembly. The Disassembly window opens, displaying the assembly instructions for the current source file.

disassembly
  1. Click the Continue button in the toolbar and continue entering input in response to the prompts in the Output window until the program is completed.

  1. When you press Enter to exit the program, your debug session ends. To end the debug session before the execution of the program was complete, you could click the Finish Debugger Session button in the toolbar or choose Debug > Finish Debugger Session.

See Also

Please see the link:https://netbeans.org/kb/trails/cnd.html[+C/C Learning Trail+] for more articles about developing with C/C/Fortran in NetBeans IDE.

link:mailto:users@cnd.netbeans.org?subject=Feedback:%20Debugging%20C/C+%20Projects%20-%20NetBeans%20IDE%207.4%20Tutorial[+Send Feedback on This Tutorial]