NetBeans IDEでのClearCaseサポートの使用

This tutorial needs a review. You can open a JIRA issue, or edit it in GitHub following these contribution guidelines.

IDEのClearCaseサポートは、IDEでの作業中に、プロジェクトに直接バージョン管理タスクを実行できるように設計されています。

このドキュメントはNetBeans IDEでのClearCaseの使用に関わる基本的な手順を説明します。

Rational ClearCaseはIBMによって開発されたバージョン管理ソフトウェア・ツールです。ClearCaseは、多くの大規模および中規模ビジネスのプロジェクトで、バージョン管理の基礎を担っています。

netbeans stamp 80 74 73
Figure 1. このページの内容は、NetBeans IDE 6.9以降に適用されます

このチュートリアルを完了するには、次のソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン

NetBeans IDE

バージョン6.9以降

Java Development Kit (JDK)

バージョン6、7または8

ClearCaseクライアント・ソフトウェア

V 7.0以降

NetBeans ClearCaseプラグイン

バージョン0.9.x以降

*注意: *NetBeans ClearCaseプラグインを入手するには、IDEのプラグイン・マネージャへ移動し(メイン・メニューから「ツール」>「プラグイン」を選択)、次に示すように、プラグインをインストールします。

cc plugin small

ClearCaseの設定

IDEのClearCaseサポートを活用するためには、コンピュータにClearCaseクライアント・ソフトウェアをインストールして実行する必要があります。

NetBeans ClearCaseサポートは、_スナップショット_と_動的_ビューの両方で動作します。*ビューは、IDE外部から構成する必要があり、ClearCaseサーバーへの接続が適切に設定されている必要があります。*スナップショット・ビューのファイルにアクセスする場合は、それ以外に何もする必要はありません。ただし動的ビューからファイルにアクセスする場合は、まずコンピュータにインストールしたネイティブClearCaseツールを使用して、動的ビューを起動します。

*注意: *

  • 現時点ではClearCase Webインタフェース(CCWeb)への接続はできません。

  • UNIX/Linuxでのシステムの制限により、ファイルにアクセスするには、動的ビューのコンテキストからIDEを起動する必要があります。

IDEのClearCaseサポートは、バージョン管理コマンドを実行するための cleartool クライアントとの対話によって機能します。システムに応じて、また、デフォルト以外の場所に cleartool クライアントをインストールしたかどうかに応じて、IDEに cleartool 実行可能ファイルのパスを登録する必要がある場合もあります。

cleartool 実行可能ファイルのパスの指定

NetBeans IDEは、コンピュータ上の $PATH システム変数を使用して、自動的に cleartool 実行可能ファイルの場所を特定しようとします。ただし、プラットフォームに応じて、または別の場所にClearCaseクライアントをインストールしたかどうかに応じて、実行可能ファイルのパスを明示的に指定する必要がある場合があります。ClearCase実行可能ファイルのパスをIDEに設定するには:

  1. メイン・メニューから「ツール」>「オプション」(Macでは「NetBeans」>「プリファレンス」)を選択します。「オプション」ダイアログが開きます。

  2. ダイアログの上部にある「その他」アイコンを選択し、「バージョン管理」タブをクリックします。「バージョン管理システム」下の左側のペインで、「ClearCase」を選択します。ダイアログのメイン・ウィンドウに、ClearCaseのユーザー定義オプションが表示されます。

    [.feature]
cc options small
  1. cleartool 実行可能ファイルのパスを指定」テキスト・フィールドに、実行可能ファイルのパスを入力するか、または「参照」をクリックしてシステム上のその場所まで移動します。

  1. 「OK」をクリックしてIDEを再起動すると、変更が有効になります。

*注意: *詳細は、NetBeans ClearCase統合設定およびリリース・ノートを参照してください。

== バージョン管理されたファイルの操作の開始

最初にIDEでClearCaseを操作する場合、既存のバージョン管理されたプロジェクトを開くか、コンピュータ上の*ClearCaseビュー内*に新しいプロジェクトを作成して開始する必要があります。

=== IDEで既存のプロジェクトを開く

すでに作業中のClearCaseバージョン管理プロジェクトがある場合、それをIDEで開くと、バージョン管理機能が自動的に使用可能になります。IDEが開いているプロジェクトをスキャンし、ClearCaseビューのディレクトリにある場合、ファイル・ステータスおよびコンテキスト依存のサポートが自動的にアクティブになります。

ClearCaseバージョン管理プロジェクトを開くには:

  1. メイン・メニューから「ファイル」>「プロジェクトを開く」を選択し、プロジェクトを開くウィザードに従って作業します。プロジェクトの場所の指定では、コンピュータ上の*ClearCaseビュー*のディレクトリ内の場所へ移動します。ウィザードを完了すると、プロジェクトが「プロジェクト」ウィンドウに表示され(Ctrl-1)、バージョン管理サポートがアクティブになります。

*注意: *「お気に入り」ウィンドウでプロジェクトまたはディレクトリを開くこともできます。ClearCaseディレクトリがNetBeansプロジェクトでない場合、これが必要になる場合があります。これを行うには、「お気に入り」ウィンドウ(Ctrl-3)を右クリックして「お気に入りに追加」を選択します。表示される「お気に入りに追加」ダイアログで、コンピュータ上のClearCaseビューのディレクトリの最上位に移動し、「追加」をクリックします。ディレクトリのツリー・ビューが「お気に入り」ウィンドウに追加されます。

=== 新規プロジェクトの作成とソース管理下への配置

新規プロジェクトを作成してClearCaseソース管理の下に配置し、IDEで作業を続けることもできます。新規プロジェクトを作成した場合、その場所を*ClearCaseビュー内*に指定する必要があります。これによってIDEはバージョン管理サポートが必要であることを認識できます。プロジェクトが作成されると、すべてのファイルは最初_view-private_になります。その後、IDEの「ソース管理に追加」コマンドを使用して、プロジェクトをClearCaseサーバーに追加できます。

新しいプロジェクトを作成するには:

  1. メイン・メニューから「ファイル」>「新規プロジェクト」を選択し、新規プロジェクト・ウィザードに従って作業します。

  2. ステップ2の「名前と場所」で、ClearCaseビューのディレクトリを選択します。

  3. 「終了」をクリックすると、プロジェクトが作成され、そのディレクトリのツリー・ビューが「プロジェクト」ウィンドウに追加されます(Ctrl-1)。 作成時、IDEはビューにプロジェクトがあることを自動的に認識し、関連するすべてのClearCaseアクションとファイル・ステータス情報が利用可能になります。

バージョン管理されたプロジェクトがIDEで開くと、すべてのファイルおよびフォルダの名前が緑色でレンダリングされ、それらが「新規」ステータスであることを示します。グレーで表示されるファイルはすべて「無視」ステータスです。詳細は、この後のバッジと色分けを参照してください。各バージョン管理プロジェクト・ファイルをバージョン管理の候補にするかどうかは、IDEが自動的に決定します。つまり、パッケージのソース・ファイルは通常バージョン管理され、プロジェクトのプライベート・ファイルは一般的には無視されます。

これでプロジェクトが作成されました。IDEの「ソース管理に追加」コマンドを使用して、ClearCaseサーバーと同期化できます。

  1. 「プロジェクト」ウィンドウでプロジェクト・ノードを右クリックし、「ソース管理に追加」を選択します。「追加」ダイアログが開き、IDEで自動的に無視されない新規view-privateファイルが表示されます。

    [.feature]
add dialog small
  1. 「説明メッセージ」テキスト領域にメッセージを入力します。または、右上隅にある「最近のメッセージ」(recent msgs)アイコンをクリックして、以前使用したメッセージのリストを表示して選択します。

  1. 個々のファイルのアクションを指定して「追加」をクリックします。「追加」アクションが実行されると、インタフェースの右下にあるIDEのステータス・バーが表示されます。追加に成功すると、「プロジェクト」、「ファイル」および「お気に入り」ウィンドウのバージョン管理バッジが消え、チェックイン・ファイルの色分けが黒に戻ります。

*注意: *「追加」ダイアログで、「追加」アクションから個々のファイルを除外するかどうかを指定できます。これを行うには、選択したファイルの「アクション」列をクリックしてドロップダウン・リストから「追加しない」を選択します。

== ソースのチェックアウト

ClearCaseバージョン管理プロジェクトをIDEで開くと、ソースを変更できます。ClearCaseバージョン管理ファイルで変更するには、最初に、チェックアウトまたは_ハイジャック_に変更する必要があります。NetBeans ClearCaseサポートには、これを行うための方法が2つあります。

  • 手動: ファイル・ノードを単純に右クリックし、「ClearCase」>「チェックアウト」(または「ClearCase」>「ハイジャック」)を選択します。

  • 要求時チェックアウト機能を使用: ファイルを書込み可能にする必要があるアクションが発生するたびに、IDEは、関連するClearCaseコマンドを自動的に実行します。たとえば、最初にエディタでファイルの内容を変更するか、またはリファクタリング・アクションを実行します。

要求時チェックアウト機能は、「ClearCaseオプション」ダイアログの要求時チェックアウト・オプションを使用して微調整できます。

== ソースの編集

NetBeans IDEで開くプロジェクトは、それらのノードをダブルクリックすると、「プロジェクト」(Ctrl-1)、「ファイル」(Ctrl-2)、「お気に入り」(Ctrl-3)ウィンドウなどのIDEのウィンドウで表示されるのと同様に、ファイルをソース・エディタで開くことができます。

IDEのソースを操作する場合、自由に使用できる様々なUIコンポーネントがあります。これらは、表示およびバージョン管理コマンドの操作で役立ちます。

=== ソース・エディタでの変更の表示

IDEのソース・エディタでバージョン管理されたファイルを開くと、リポジトリから以前にチェックアウトしたバージョンに照らしあわせながら、そのファイルに行われた変更がリアル・タイムで表示されます。作業に伴って、IDEはソース・エディタのマージンに色分けを使用し、次の情報を伝えます。

(     ) 古いバージョンの後で変更された行を示します。

(     )

古いバージョンの後で追加された行を示します。

(     )

古いバージョンの後で除去された行を示します。

ソース・エディタの左側のマージンには、行ごとに発生した変更が表示されています。行を変更すると、その変更がすぐに左側のマージンに表示されます。

マージンの色のグループをクリックすると、新しく加えた変更を元に戻すことができます。たとえば、左下のスクリーン・ショットに、赤いアイコンをクリックすると使用可能なウィジェットが表示され、チェックアウトしたファイルからその行が除去されたことを示します。

ソース・エディタの右側のマージンには、上から下に向かって、ファイル全体に行われた変更の概要が表示されます。ファイルに変更を行うと、すぐに色分けが生成されます。

マージンの特定の場所をクリックすると、インライン・カーソルがファイルのその場所にすぐに移動します。影響を受ける行数を表示するには、右側のマージンの色つきアイコンの上にマウスを動かします。

[.feature]

left ui small

左側のマージン |right ui 右側のマージン

=== ファイルのステータス情報の表示

「プロジェクト」(Ctrl-1)、「ファイル」(Ctrl-2)、「お気に入り」(Ctrl-3)または「バージョン管理」ウィンドウで作業する場合、IDEには、ファイルのステータス情報を表示するのに役立つ視覚機能がいくつかあります。次の例では、バッジ(例: blue badge)、ファイル名の色、および隣接するステータス・ラベルすべての相互の対応方法を確認し、ファイルに対するバージョン管理情報をトラックする単純だが効果的な方法について説明します。

image::images/badge-example.jpg[title="「お気に入り」ウィンドウに表示された青のバージョン管理バッジ"]

バッジ、色分け、ファイル・ステータス・ラベル、およびおそらく最も重要なバージョン管理ウィンドウはすべて、効果的な表示および管理能力、およびIDEでのバージョン管理情報に貢献します。

* バッジと色分け * ファイル・ステータス・ラベル * バージョン管理ウィンドウ

==== バッジと色分け

バッジはプロジェクト、フォルダおよびパッケージ・ノードに適用され、そのノードに含まれているファイルのステータスを示します。

バッジに使用される色のスキームを次の表に示します。

|UIコンポーネント |説明

|青のバッジ(blue badge) |チェックアウト、ハイジャック、または追加されたファイルまたはフォルダがあることを示します。パッケージの場合、このバッジは、パッケージ自体にのみ適用され、そのサブパッケージには適用されません。プロジェクトまたはフォルダの場合、このバッジはその項目または含まれるサブフォルダ内の内容の変更を示します。

色分けは、現在のステータスを示す目的でファイル名に適用されます。

|色 |例 |説明

| |blue text |ファイルがチェックアウトされたことを示します。

| |green text |ファイルが新規で、ソース管理にまだ追加されていないことを示します。

|グレー |gray text |ファイルがClearCaseに無視され、バージョン管理コマンド(「ソース管理に追加」または「チェックイン」)に含まれていないことを示します。まだバージョン管理されていない場合にのみ、ファイルが無視されます。

|取消し線 |strike through text |ファイルがチェックインまたは「ソース管理に追加」操作から除外されたことを示します。取消し線テキストは、アクションから個別ファイルを除外することを選択した場合に、「バージョン管理」ウィンドウ、チェックイン・ダイアログ、および「ソース管理に追加」ダイアログなどの特定の場所にのみ表示されます。そのようなファイルは、「更新」など、他のClearCaseコマンドの影響はまだ受けます。

==== ファイル・ステータス・ラベル

ファイル・ステータス・ラベルは、バージョン管理ファイルのステータスを、IDEのウィンドウにテキストで示します。デフォルトで、IDEは、ファイルをウィンドウに一覧表示するときに、そのファイルの右側にステータス情報(新規、予約済、予約なし、無視など)をグレー・テキストで表示します。ただし、この形式は独自のものに変更できます。たとえば、バージョン・セレクタをステータス・ラベルに追加する場合は、次のようにします。

1. メイン・メニューから「ツール」>「オプション」(Macでは「NetBeans」>「プリファレンス」)を選択します。「オプション」ウィンドウが開きます。 2. ウィンドウの上部にある「その他」ボタンを選択し、その下にある「バージョン管理」タブをクリックします。左側のパネルの「バージョン管理システム」の下のClearCaseが選択されていることを確認します。詳細は前述のスクリーン・ショットを参照してください。 3. 「ステータス・ラベル形式」テキスト・フィールドの右側の「変数を追加」ボタンをクリックします。表示される「変数を追加」ダイアログで v2.5.1 変数を選択し、「OK」をクリックします。「ステータス・ラベル形式」テキスト・フィールドに、バージョン変数が追加されます。 4. ファイルの右側にステータスとバージョン・セレクタのみが表示されるようにステータス・ラベルを再フォーマットするには、「ステータス・ラベル形式」テキスト・フィールドの内容を次のように再整理します。

[source,java] ----

[{status}; v2.5.1] ---- 「OK」をクリックします。これでステータス・ラベルにはファイルのステータスとバージョン・セレクタ(該当する場合)が表示されます。

image::images/file-labels.jpg[title="ファイル名の横に表示されたファイル・ラベル"]

ファイル・ステータス・ラベルは、メイン・メニューから「表示」>「バージョン・ラベルを表示」を選択して、オンとオフを切り替えできます。

==== バージョン管理ウィンドウ

ClearCaseバージョン管理ウィンドウは、ローカルの作業コピーの選択されたフォルダ内でファイルに行われた変更のすべてを、リアル・タイムで一覧表示します。これは、IDEの下のパネルにデフォルトで開き、新規、チェックアウト、またはハイジャックされたファイルを一覧表示します。

バージョン管理ウィンドウを開くには、(「プロジェクト」ウィンドウ、「ファイル」ウィンドウ、または「お気に入り」ウィンドウなどから)バージョン管理ファイルまたはフォルダを選択し、右クリック・メニューから「ClearCase」>「変更を表示」を選択するか、またはメイン・メニューから「バージョン管理」>「変更を表示」を選択します。IDEの最下部に次のウィンドウが表示されます。

[.feature]

versioning window small

デフォルトでは、「バージョン管理」ウィンドウは選択したパッケージまたはフォルダに含まれる、注目が必要な状態(新規、予約済、予約なしなど)を示す、すべてのファイルを一覧表示します。表示されたファイル一覧の列の見出しをクリックして、名前、ステータス、場所、またはルールでファイルをソートすることもできます。

「バージョン管理」ウィンドウのツールバーには、一覧に表示されているすべてのファイルについて、頻繁に使用されるClearCaseタスクを呼び出せるボタンも用意されています。次の表は、「バージョン管理」ウィンドウのツールバーにあるClearCaseコマンドをまとめています。

アイコン 名前 機能

refresh

ステータスのリフレッシュ

選択したファイルとフォルダのステータスをリフレッシュします。「バージョン管理」ウィンドウに表示されたファイルは、外部で行われた可能性のある任意の変更を反映してリフレッシュできます。

diff

すべて差分を取得

差分ビューアを開くと、リポジトリで保持されているバージョンとローカルの変更を並べた比較が表示されます。

update

すべて更新

選択したファイルをすべて更新します。スナップショット・ビューにのみ適用されます。

commit

すべてチェックイン

ローカルでの変更をすべてチェックインできます。

「バージョン管理」ウィンドウで、ファイルに対応する表行を選択し、右クリック・メニューからコマンドを選択すると、他のClearCaseコマンドにアクセスできます。

versioning right click
Figure 2. 「バージョン管理」ウィンドウの選択したファイルに対して表示された右クリック・メニュー

たとえば、ファイルでは次のアクションを実行できます。

* 注釈を表示:

ソース・エディタで開かれているファイルの左マージンに、作成者、リビジョン番号情報を表示します。

[.feature]

annotations small

|* チェックインから除外:

チェックインを実行するときに除外するファイルをマークできます。 |exclude from checkin

=== ファイル・バージョンの比較

ファイル・バージョンの比較は、バージョン管理されているプロジェクトでの作業で共通のタスクです。差分コマンドを使用すると、IDEでバージョンの比較が行えます。差分コマンドは、「バージョン管理」ウィンドウまたは選択した項目の右クリック・メニュー(「ClearCase」>「差分」)から使用できます。「バージョン管理」ウィンドウで、差分を実行するには、リストされているファイルをダブルクリックするか、上部のツールバーにある「すべて差分を取得」アイコン(diff)をクリックします。

差分の取得を実行すると、選択したファイルについてグラフィカルな差分ビューアがIDEのメイン・ウィンドウで開きます。次のように、差分ビューアには2つのコピーが並んだパネルに表示されます。

[.feature]

diff viewer small

差分ビューアは、バージョン管理の変更を表示する場所に使用されているのと同じ色分けを利用します。前に表示したスクリーン・ショットの緑色のブロックは、より現在に近いバージョンで追加された内容を示します。赤いブロックは、前のバージョンの内容が、より最近のバージョンで除去されたことを示します。青は、強調表示された行で変更が発生したことを示します。

また、プロジェクト、パッケージまたはフォルダなどのグループで差分を実行する場合、あるいは「すべて差分を取得」(diff)をクリックする場合は、差分ビューアの上部領域にリストされているファイルをクリックすると、差分を切り替えることができます。

差分ビューアには次の機能もあります。

==== チェックアウトしたファイルへの変更の実行

チェックアウトしたファイルで差分の取得を実行する場合、差分ビューア内で直接変更を行うことができます。これを行うには、カーソルを差分ビューアの右ペインに置き、それに従ってファイルを変更するか、または強調表示された各変更の前後で表示されるインライン・アイコンを使用します。

置換(insert): 強調表示された前のバージョンのテキストを、チェックアウトしたバージョンへ挿入します。

すべて移動(arrow):

ファイルのチェックアウトしたバージョンを、選択された以前のバージョンの状態に戻します。

除去(remove):

強調表示されたテキストをチェックアウトしたバージョンから除去し、前のバージョンが反映されるようにします。

==== 比較したファイルの相違間をナビゲート

差分に複数の違いが含まれている場合、ツールバーに表示された矢印アイコンを使用して、それらをナビゲートできます。矢印アイコンを使用すると、差分を上から下へ出現順に表示できます。

(diff prev): 差分内で、前に表示された差分に移動します。

(diff next):

差分内で、次に表示された差分に移動します。

== ソースのチェックイン

ソースに変更を加えた後は、それをリポジトリにチェックインします。IDEを使用すると、チェックイン・コマンドを次の方法でコールできます。

  • 「プロジェクト」、「ファイル」または「お気に入り」ウィンドウで、新規またはチェックアウトした項目を右クリックし、「ClearCase」>「チェックイン」を選択します。

  • 「バージョン管理」ウィンドウまたは差分ビューアから、ツールバーにある「すべてチェックイン」(commit)ボタンをクリックします。

「チェックイン」ダイアログが開き、次が表示されます。

  • すべてのチェックアウト・ファイル

  • すべての新規ファイル。最初に、ソース管理に自動で追加されます。つまり、まだバージョン管理されておらず、IDEに無視されていないview-privateファイルです。

checkin dialog small

「チェックイン」ダイアログで、「チェックイン」から個々のファイルを除外するかどうかを指定できます。これを行うには、選択したファイルの「チェックイン・アクション」列をクリックしてドロップダウン・リストから「チェックインから除外」を選択します。

チェックインを実行するには:

  1. 「チェックイン・メッセージ」テキスト領域にチェックイン・メッセージを入力します。または、右上隅にある「最近のメッセージ」(recent msgs)アイコンをクリックして、以前使用したメッセージのリストを表示して選択します。

  2. 個々のファイルのアクションを指定して「チェックイン」をクリックします。IDEがチェックインを実行します。インタフェースの右下にあるIDEのステータス・バーに、チェックイン・アクションの実行状況が表示されます。チェックインに成功すると、「プロジェクト」、「ファイル」および「お気に入り」ウィンドウのバージョン管理バッジが消え、チェックイン・ファイルの色分けが黒に戻ります。 このチュートリアルに関するご意見をお寄せください

== 関連項目

これで、NetBeans IDEでのClearCaseのガイド・ツアーは終了です。このドキュメントでは、IDEのClearCaseサポートを使用する場合の標準的なワークフローを説明することによって、IDEの基本的なバージョン管理タスクの実行方法を示しました。

関連するドキュメントについては、次のリソースを参照してください。